Back to overview
Resolved

Notifications & Live flight info falling behind

Mar 16, 2026 at 8:13pm UTC
Affected services
Notifications & Alerts
Live Flight Info (Gate/Inbound/Status/etc)

Resolved
Mar 16, 2026 at 8:27pm UTC

We're back! Notifications and flight alerts are back to realtime. Thanks for your patience.

Updated
Mar 16, 2026 at 8:19pm UTC

The notification and flight alerts server is back online and catching up. We should be back to realtime in the next few minutes.

Created
Mar 16, 2026 at 8:13pm UTC

Our server that communicates with Flight Aware for live flight updates and Firebase for push notifications/alerts was falling behind. We found an issue and brought the server offline temporarily for updates. We should be back online in the next 5 to 10 minutes. Normal refresh and other in-app information is unaffected.