Back to overview
Resolved
Flight status updates are falling behind
Mar 24, 2026 at 3:26pm UTC
Affected services
Live Flight Info (Gate/Inbound/Status/etc)
Resolved
Mar 24, 2026 at 4:18pm UTC
Flight status updates are back to live. Thanks for your patience.
Affected services
Updated
Mar 24, 2026 at 4:05pm UTC
After several attempts at restarting the connection, we were finally able to get a stable link and the flights are currently working through the backlog of updates. It should be back to realtime in the next 5 or 10 minutes.
Affected services
Created
Mar 24, 2026 at 3:26pm UTC
Our connection to FlightAware's firehose service is falling behind. We are working on it and will restore realtime flight status info soon.
Affected services