Back to overview
Resolved
The number of current Mesa Airlines flights is below a minimum threshold.
Jul 4, 2026 at 9:22pm UTC
Affected services
Live Flight Info (Gate/Inbound/Status/etc)
Resolved
Jul 4, 2026 at 11:03pm UTC
This monitor recovered on its own at 6:03pm on July 4th. This update was posted late at 7:46am, July 5th.
Affected services
Created
Jul 4, 2026 at 9:22pm UTC
The service is not currently degraded. Our servers monitor specific airlines to make sure gate and flight status info is available for all flights. When the number of flights with available flight statuses drops below a low enough threshold, this monitor triggers. The number of flights currently actually being operated or scheduled by Mesa is below that threshold. We will update this monitor to reflect this.
Affected services